mirror of
https://github.com/notherealmarco/coredns-deployment.git
synced 2025-05-05 04:28:38 +02:00
16 lines
300 B
Bash
16 lines
300 B
Bash
#!/bin/sh
|
|
|
|
set -e
|
|
|
|
case "$1" in
|
|
configure)
|
|
if ! getent passwd coredns > /dev/null; then
|
|
adduser --system --disabled-password --disabled-login --home /var/lib/coredns \
|
|
--quiet --force-badname --group coredns
|
|
fi
|
|
;;
|
|
esac
|
|
|
|
#DEBHELPER#
|
|
|
|
exit 0
|